好股
添加说明
您现在的位置:首页 >> 参考指标 >> 内容
请输入牛散姓名,如: 国通信托 ,紫金8号 ,周信钢 ,李欣 ,周晨 ,赵建平 ,徐开东 ,淡水泉 ,马云
请输入完整股票代码如 000001 ,600276 ,300699 ,600436 ,600519 ,603866 ,000538 ,600315 ,000651

或完整名称如: 平安银行 恒瑞医药 光威复材 片仔癀 贵州茅台 桃李面包 云南白药 上海家化 格力电器
请输入股票代码,如: 000001 ,600276 ,300699 ,600436 ,600519 ,603866 ,000538 ,600315 ,000651

部分VIP查询功能限时开放=《     私募总数在五个以上个股     阳光私募在五个以上个股     个人私募在五个以上个股     》=部分VIP查询功能限时开放

【通达信】股东户数、户均持股自定义数据

时间:2018-1-17 23:19:10 点击:

  核心提示:通达信V5.895版本增加了“专业财务函数”和“专业财务数据”,使用新版本的朋友,以后可以不用每天下载自定义数据了。只要每天更新“专业财务数据”即可,建议大家升级到新版。自定义数据会不定期更新。下图为...
通达信V5.895版本增加了“专业财务函数”和“专业财务数据”,使用新版本的朋友,以后可以不用每天下载自定义数据了。只要每天更新“专业财务数据”即可,建议大家升级到新版。自定义数据会不定期更新。
下图为使用“专业财务数据”的效果:

{以下为使用新版“专业财务数据”的公式}
{股东户数}
HS:=FINVALUE(242);
AA:=HS<>REF(HS,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
HSS:=REF(HS,BB+1);
幅度:=(HS/HSS-1)*100;
IF(CC=0,PLOYLINE(AA,HS),DRAWNULL),COLORGREEN;
DRAWBMP(AA,HS,'YELLOWBOLLX');

BGQ:=FINVALUE(0);
Z1:=STRCAT('公告日期:20',CON2STR(BGQ,0));
Z2:=STRCAT(' 幅度:',CON2STR(幅度,2));
Z3:=STRCAT(Z2,'%');
Z4:=STRCAT(Z1,Z3);
DRAWTEXT_FIX(BB,0.8,0,0,Z4),COLOR00FFFF;

{户均持股}
HS:=FINVALUE(242);
CG:=FINVALUE(239)/HS;
AA:=CG<>REF(CG,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
CGS:=REF(CG,BB+1);
幅度:=(CG/CGS-1)*100;
IF(CC=0,PLOYLINE(AA,CG),DRAWNULL),COLORRED;
DRAWBMP(AA,CG,'YELLOWBOLLX');

Z1:=STRCAT('幅度:',CON2STR(幅度,2));
Z2:=STRCAT(Z1,'%');
DRAWTEXT_FIX(BB,0.91,0.2,0,Z2),COLOR00FFFF;

机构数:=FINVALUE(246);
机构占比:=100*FINVALUE(247)/FINVALUE(239);
QFII数:=FINVALUE(248);
QFII占比:=100*FINVALUE(249)/FINVALUE(239);
券商数:=FINVALUE(250);
券商占比:=100*FINVALUE(251)/FINVALUE(239);
保险数:=FINVALUE(252);
保险占比:=100*FINVALUE(253)/FINVALUE(239);
基金数:=FINVALUE(254);
基金占比:=100*FINVALUE(255)/FINVALUE(239);
社保数:=FINVALUE(256);
社保占比:=100*FINVALUE(257)/FINVALUE(239);
私募数:=FINVALUE(258);
私募占比:=100*FINVALUE(259)/FINVALUE(239);
流通占比:=100*FINVALUE(244)/FINVALUE(239);
BGQ:=FINVALUE(0);
DRAWTEXT_FIX(PERIOD=5,0,0,0,STRCAT('机构持仓比例: 20',CON2STR(BGQ,0))),COLOR0080FF;
A11:=STRCAT(CON2STR(IF(基金数=DRAWNULL,0,基金数),0),'家');
A12:=STRCAT(CON2STR(IF(基金占比=DRAWNULL,0,基金占比),2),'%');
A13:=STRCAT(A11,A12);
DRAWTEXT_FIX(PERIOD=5,0.14,0,0,STRCAT('基金:',A13)),COLOR0080FF;
A21:=STRCAT(CON2STR(IF(QFII数=DRAWNULL,0,QFII数),0),'家');
A22:=STRCAT(CON2STR(IF(QFII占比=DRAWNULL,0,QFII占比),2),'%');
A23:=STRCAT(A21,A22);
DRAWTEXT_FIX(PERIOD=5,0.23,0,0,STRCAT('QFII:',A23)),COLOR0080FF;
A31:=STRCAT(CON2STR(IF(社保数=DRAWNULL,0,社保数),0),'家');
A32:=STRCAT(CON2STR(IF(社保占比=DRAWNULL,0,社保占比),2),'%');
A33:=STRCAT(A31,A32);
DRAWTEXT_FIX(PERIOD=5,0.31,0,0,STRCAT('社保:',A33)),COLOR0080FF;
A41:=STRCAT(CON2STR(IF(保险数=DRAWNULL,0,保险数),0),'家');
A42:=STRCAT(CON2STR(IF(保险占比=DRAWNULL,0,保险占比),2),'%');
A43:=STRCAT(A41,A42);
DRAWTEXT_FIX(PERIOD=5,0.4,0,0,STRCAT('保险:',A43)),COLOR0080FF;
A51:=STRCAT(CON2STR(IF(券商数=DRAWNULL,0,券商数),0),'家');
A52:=STRCAT(CON2STR(IF(券商占比=DRAWNULL,0,券商占比),2),'%');
A53:=STRCAT(A51,A52);
DRAWTEXT_FIX(PERIOD=5,0.49,0,0,STRCAT('券商:',A53)),COLOR0080FF;
A61:=STRCAT(CON2STR(IF(私募数=DRAWNULL,0,私募数),0),'家');
A62:=STRCAT(CON2STR(IF(私募占比=DRAWNULL,0,私募占比),2),'%');
A63:=STRCAT(A61,A62);
DRAWTEXT_FIX(PERIOD=5,0.58,0,0,STRCAT('私募:',A63)),COLOR0080FF;
A71:=STRCAT(CON2STR(IF(机构数=DRAWNULL,0,机构数),0),'家');
A72:=STRCAT(CON2STR(IF(机构占比=DRAWNULL,0,机构占比),2),'%');
A73:=STRCAT(A71,A72);
DRAWTEXT_FIX(PERIOD=5,0.67,0,0,STRCAT('机构汇总:',A73)),COLOR0080FF;
A81:=STRCAT(CON2STR(流通占比,2),'%');
DRAWTEXT_FIX(PERIOD=5,0.78,0,0,STRCAT('十大流通股东占比:',A81)),COLOR0080FF;

{以下为自定义数据用}
需要在通达信自定义数据管理器,分别建立股东户数、户均持股的自定义数据,属性为“序列数据”。

公式:
{股东户数}
HS:=SIGNALS_USER(41,1);{此处数值改为自己实际数值}
AA:=HS<>REF(HS,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
HSS:=REF(HS,BB+1);
幅度:=(HS/HSS-1)*100;
IF(CC=0,PLOYLINE(AA,HS),DRAWNULL),COLORGREEN;
DRAWBMP(AA,HS,'YELLOWBOLLX');
Z1:=STRCAT(' ',CON2STR(REF(YEAR,BB),0));
Z2:=STRCAT(Z1,'-');
Z3:=STRCAT(Z2,CON2STR(REF(MONTH,BB),0));
Z4:=STRCAT(Z3,'-');
Z5:=STRCAT(Z4,CON2STR(REF(DAY,BB),0));
Z6:=STRCAT('公告日期:',Z5);
Z7:=STRCAT(Z6,'  幅度:');
Z8:=STRCAT(Z7,CON2STR(幅度,2));
Z9:=STRCAT(Z8,'%');
DRAWTEXT_FIX(BB,0.8,0,0,Z9),COLOR00FFFF;

{户均持股}
CG:=SIGNALS_USER(42,1);{此处数值改为自己实际数值}
AA:=CG<>REF(CG,1);
BB:=BARSLAST(AA);
CC:=BACKSET(ISLASTBAR,BB);
CGS:=REF(CG,BB+1);
幅度:=(CG/CGS-1)*100;
IF(CC=0,PLOYLINE(AA,CG),DRAWNULL),COLORRED;
DRAWBMP(AA,CG,'YELLOWBOLLX');
Z1:=STRCAT('幅度:',CON2STR(幅度,2));
Z2:=STRCAT(Z1,'%');
DRAWTEXT_FIX(BB,0.91,0.2,0,Z2),COLOR00FFFF; {下移}
DRAWTEXT_FIX(PERIOD=5,0.0,0.0,0,STRCAT('机构持仓比例: ',EXTERNSTR(0,44))),COLOR0080FF;

作者:有好股 来源:有好股
淘江湖 新浪微薄 腾讯微博 QQ空间 开心网 人人网 豆瓣网 网易微博 百度空间 鲜果 白社会 飞信 
共有评论 0相关评论
发表我的评论
  • 大名:
  • 内容:
  • 有好股(www.uhaogu.com) © 2018 版权所有 All Rights Reserved.
  • QQ:317197119 闽ICP备14004870号-8